Author Topic: ...and another PreenFM built in the USA one issue - MIDI sequencing  (Read 4411 times)

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Merci Xavier,

Received my PreenFM at work yesterday (Colorado!), and built it in about 2 hours or so. Very straightforward build, and like the others, I thought the resistor sheet was a nice touch.

I only had a little bit of time to test it out and everything seems to work so far, except when I try to sequence it via MIDI with either a GORF sequencer (hardware) or via Ableton Live. The notes stutter, but it does receive note on/off from an external controller. The PreenFM is running rev 1.5 as shipped, and I'll try reloading the firmware or rolling it back to an earlier version. I was running USB power form my Mac and I also tried through a USB wallwart with the same results.

Any ideas?

FP

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1305
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #1 on: January 18, 2012, 09:23:40 PM »

Hi, thanks for the feedback.

I'm not sure i get it.
With an external controller (mid keyboard ?) it works.

But with Ableton Live and with your hardware sequener there's a problem ? Right ?
What is the exact problem ? Notes don't stop ? They are cut ? they are played several times ?

Do you replay something you record with a keyboard or do you use a kind of midi algorithm to send the notes ?
I may be wrong, but I suspect the midi notes to arrive too quickly and as PreenFM polyphony is limited, the rendering is not smooth.

I doubt trying with an other firmware will solve anything.

Could you record the midi that makes the note stuterring in a midi file and send it to me ?
I'd like also to hear what you hear ? Could you record it ?

Xavier


Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #2 on: January 18, 2012, 09:34:16 PM »
I'll record it tonight (audio and midi). It does play correctly with a midi keyboard, but as soon as I start a midi sequence from the piano roll in Ableton (basic notes, no CC's or anything) the Preen makes a series of quick notes as if it were playing staccato and it eats up the polyphony. It does sound like it's being overloaded and unable to keep up.

Anyway, I'll put something up in a few hours when I get off work.

FP

loderbast

  • Team member
  • *
  • Posts: 10
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #3 on: January 18, 2012, 10:18:04 PM »
i had a similar problem today.

works perfectly fine when getting midi directly from midi keyboard.

when it is at some point in a midi chain, it seemes to get buffer overflow or something.
about 1/2 of recieved notes get stuck or won`t play at all.
tryed different midi interfaces.

i had no time to test it some more, but it looked to me like error from to much recieved midi. i think i had some stuff playing on other chanels. i will have time to test some more over the weekend.
is it possible it will get buffer overflow from midi active sensing or something?
i am not sure, but i think i tried qith and qithout through option enabled


other than that, the synth is great!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1305
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #4 on: January 18, 2012, 11:10:22 PM »
That's bad. I have to fix that.

Loderbast, do you also use ableton live ?
I just tried several midi config with Reaper and i could not reproduce anything like this.

If you have a midi file I could use that would be great ?
Also, i'm currently downloading a Free-30 days live trial version. Maybe the problem will be obvious with live.

Xavier

« Last Edit: January 18, 2012, 11:32:52 PM by Xavier »

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #5 on: January 19, 2012, 03:30:40 AM »
Here's a sample clip, recorded from Ableton Live.

http://soundcloud.com/fresh-pants/preenfm-test

I notice that even if there isn't a file/sequence being played, that the MIDI start causes the PreenFM to garble (similar stutter-ey sounds) any of the MIDI keyboard input too.

The midi file I used is attached, it isn't anything special.

FP

loderbast

  • Team member
  • *
  • Posts: 10
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #6 on: January 19, 2012, 07:50:53 AM »
i also use ableton live...

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1305
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #7 on: January 19, 2012, 08:09:17 PM »
OK thanks.
I think i know what happens.

In Ableton Live, can you disable "Midi TimeCode" for the midi output sent to the PreenFM ?

I hadn't realized Midi TimeCode sends information with the SysEx protocol.
The PreenFM Audio engine stops while waiting for the end of SysEx messages which can make these little audio glitches...
I'll confirm that soon. I didn't check with the code yet.

Xavier
« Last Edit: January 19, 2012, 08:38:40 PM by Xavier »

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #8 on: January 19, 2012, 08:49:11 PM »
Hmm...

This morning I tried to sequence the PreenFM with an FR777, but it still reacts the same way as it does when sequenced by Ableton or from the GorF sequencer. I don't think the FR777 or the GorF outputs MTC. Curious.

FP
« Last Edit: January 19, 2012, 10:38:11 PM by Fresh Pants »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1305
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #9 on: January 19, 2012, 11:18:47 PM »

Simple Midi clock also broke the audio engine.
It should be fixed in 1.51.B1...

To download here :
http://xhosxe.free.fr/PreenFM/firmware/BETA/

How to upgrade :
https://sites.google.com/site/preenfm/firmwares

Please, let me know if it solves anything on your side.
Thanks for your help  :D

Xavier

Xavier

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #10 on: January 20, 2012, 12:20:12 AM »
Merci Xavier.

I'll update the firmware when I get home and post results up here.

 8)

FP

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #11 on: January 20, 2012, 03:48:57 AM »
 ;D

Woo hoo!
Everything seems to be working now.

Xavier, thanks again for all the work you put into the PreenFM for us to enjoy.   :)

FP

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1305
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #12 on: January 20, 2012, 09:38:04 AM »
Great !  :D
Thank you for the fast confirmation... and for having reported this bug.

Now i have to reflash the 45 maple minis that are waiting to be packaged... Aouch...


Xavier
« Last Edit: January 20, 2012, 10:50:48 AM by Xavier »

Fresh Pants

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: ...and another PreenFM built in the USA one issue - MIDI sequencing
« Reply #13 on: January 20, 2012, 06:38:33 PM »
You're welcome, I'm glad I could be of service.
And thank you again for correcting the bug quickly.

Good luck with flashing all those Maple Minis. :)

FP