Author Topic: Bootloader & Fimware  (Read 2296 times)

Kentucky

  • Team member
  • *
  • Posts: 14
    • View Profile
Bootloader & Fimware
« on: June 01, 2014, 11:23:38 AM »
 hello,

La petite boîte est enfin assemblée  :P  - correctement, j'espère  :o - mais je suis bloqué pour la faire démarrer ; j'ai installé le driver avec Zadig, par contre je ne suis pas sûr de faire ce qu'il faut avec les fichiers dfu, ni d'avoir pris les bons... j'ai téléchargé le dossier "dfu-util-0.6-win32.zip" qui semble être la dernière version pour Windows (en tout cas, contenant "win32"). Premier truc bizarre : je ne trouve pas "dfu-util-static.exe". J'ai copié les 3 autres fichiers dans le répertoire "Build".

J'ai téléchargé le bootloader et le firmware, lancé le bootloader (j'ai un écran de commandes pendant quelques secondes) puis le firmware :  à nouveau, écran de commande et cette ligne qui paraît problématique : "no valid dfu suffix signature" ; puis l'écran disparaît, et rien ne se passe. Ecran noir sur le PMF2.

je ne vois pas quoi faire avec ça, dans les instructions :

"If nothing works, check that dfu-util sees

>dfu-util -l

dfu-util 0.7"

voilà... Merci de m'éclairer, j'ai sans doute raté un truc.

PS : je suis sous Windows 7
PS2 : je suis nul en informatique
PS3 : quelle beau petit boitier ! hâte que ça fonctionne !!  :P


Kentucky

  • Team member
  • *
  • Posts: 14
    • View Profile
Re: Bootloader & Fimware
« Reply #1 on: June 01, 2014, 01:50:42 PM »
J'ai fini par trouver les 4 fichiers "dfu-suffix.exe, dfu-util.exe, dfu-util-static.exe, libusb-1.O.dll" dans le répertoire "dfu-util-0.7-binaries.7z" du lien http://dfu-util.gnumonks.org/releases/, comme indiqué quelque part sur le forum ; je les ai collés dans mon répertoire Build, j'ai relancé "install bootloader" et "installfirmware", mais le résultat est le même... Ecran noir et pas de disque / matériel visible dans mon poste de travail...  :-\

Une idée ?

Edit : le STM32 BOOTLOADER apparaît bien dans mes périphériques, cf capture d'écran...





« Last Edit: June 01, 2014, 01:58:17 PM by Kentucky »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1129
    • View Profile
Re: Bootloader & Fimware
« Reply #2 on: June 01, 2014, 10:03:01 PM »
Salut Kentucky,

Premiere question, pourquoi tu veux flasher le firmware par la méthode du DFU?
Je viens de vérifier et tu as reçu un Kit avec le preenf405 prêt a l'emploi.

Tu n'as aucune raison de devoir te battre avec le "STM32 BOOTLOADER".
Comme je ne sais pas ce que tu as fait exactement, je ne sais pas dans quel état est ton STM32 (le microcontrolleur).
Tu as reflashé le bootloader et le firmware ? Le flashage s'est bien passé ?

Le jumper JMP3 doit être non connecté. Est-ce bien le cas ?
S'il est connecté, le preenfm2 ne boot pas et se met en mode DFU avec un écran noir.






Kentucky

  • Team member
  • *
  • Posts: 14
    • View Profile
Re: Bootloader & Fimware
« Reply #3 on: June 01, 2014, 10:50:14 PM »
ça y est ça marche !  :D

merci Xavier pour cette réponse rapide, rhooo... j'avais juste mal compris les instructions concernant le "jumper 3"... que j'ai simplement déconnecté et c'est bon  :-[

Trop content ; c'est mon premier synth DIY et franchement j'ai pas toujours fait le malin hier avec le fer à souder.




Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1129
    • View Profile
Re: Bootloader & Fimware
« Reply #4 on: June 02, 2014, 10:22:21 AM »
Trop content ; c'est mon premier synth DIY et franchement j'ai pas toujours fait le malin hier avec le fer à souder.

Excellent !   :D
N'hésite pas si tu as d'autres questions.

Kentucky

  • Team member
  • *
  • Posts: 14
    • View Profile
Re: Bootloader & Fimware
« Reply #5 on: June 02, 2014, 09:31:03 PM »
N'hésite pas si tu as d'autres questions.

J'en aurai sûrement !  :)

En voilà une première (je peux ouvrir un autre thread sur le sujet, ptet ?) : l'alim via usb fonctionne correctement, par contre j'ai essayé via l'entrée DC in avec un adapateur de Microkorg (9V / 600 mA), sans trop me poser de questions... et ça ne marche pas (du tout, rien à l'écran). Je suspecte une mauvaise soudure qqpart, mais a priori pas au niveau de la prise "DC connector". Est-ce qu'il y a des points à vérifier en priorité ?

Sinon, j'envisage d'utiliser l'USB uniquement pour l'alim (ce qui serait plus simple pour moi, à vrai dire) ; j'ai un adaptateur USB de téléphone qui dit : 5V / 750 mA, et un autre de console de jeux qui dit : 5V / 1500 mA. Est-ce que je peux tenter ça sans risque de tout faire cramer ?  ???




Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1129
    • View Profile
Re: Bootloader & Fimware
« Reply #6 on: June 02, 2014, 10:59:25 PM »

Tu as bien le JMP1 en place ?
C'est lui qui (de)connecte le DC in.

Sinon tu peux revérifier que les 2 diodes sont dans le bon sens ainsi que le régulateur 7805.

La seul contrainte de l'adaptateur et que le + doit être au centre et le - autour. Schéma de gauche ici :
http://images.ncix.com/forumimages/2FFA97B7-8CA6-4C46-A1F10659651E6CEF.jpg
Vérifie que c'est bien ce que tu as sur ton adaptateur.

Aucun problème pour tes transfo USB. Le preenfm2 consomme a peu prêt 150mA donc les 2 devraient fonctionner sans problème.
Le courant indiqué (750 / 1500) est le max que peut fournir l'adaptateur.


Kentucky

  • Team member
  • *
  • Posts: 14
    • View Profile
Re: Bootloader & Fimware
« Reply #7 on: June 02, 2014, 11:07:08 PM »

La seul contrainte de l'adaptateur et que le + doit être au centre et le - autour. Schéma de gauche ici :
http://images.ncix.com/forumimages/2FFA97B7-8CA6-4C46-A1F10659651E6CEF.jpg
Vérifie que c'est bien ce que tu as sur ton adaptateur.

Aucun problème pour tes transfo USB. Le preenfm2 consomme a peu prêt 150mA donc les 2 devraient fonctionner sans problème.
Le courant indiqué (750 / 1500) est le max que peut fournir l'adaptateur.

Ah voilà, effectivement les polarités de mon adaptateur sont l'inverse de ce qu'il faudrait... Sinon pour le reste normalement tout est bon (polarité des diodes, jumper & régulateur) ; je vais tester avec mes adaptateurs USB si je ne trouve pas le bon adaptateur dC.

Merci !