Author Topic: [Resolved in 2.05B5] OS 2.03: behaviour NOT1/2 ==> IM*  (Read 597 times)

TSR

  • Team member
  • *
  • Posts: 8
    • View Profile
[Resolved in 2.05B5] OS 2.03: behaviour NOT1/2 ==> IM*
« on: September 02, 2016, 01:41:46 PM »
OS 2.03

For most patches, I apply note scaling to all modulation indexes in order to cure harsh high notes.

See here from the manual: "Decrease the IM for high notes to get rid of aliasing. ( Flat, 60, -lin8) that you multiply by IM* in the modulation matrix."

It seems that setting up "NOT1/2 ==> IM*" in the matrix only adds to all fixed modulation indexes: When setting all fixed IMs to 0.00, and setting the velocity sensitive IMs different from 0.00, the aforementioned matrix entry has no effect at all.

Speaking in simple math, it seems to be implemented similar to this: (fixed IMs * matrix setting) + velocity sensitive IMs
I'd like to see it implemented the following way: (fixed IMs + velocity sensitive IMs) * matrix setting

This way, you could add velocity sensitive growl to the lower notes, that does not lead to harsh sounds in the higher notes. (Heading for piano type sounds here.)

Alternatively, one could add a new destination, e.g.  "IMvel*", which only applies to the velocity sensitive modulation indexes. This would even offer higher flexibility.

Does this make sense at all?
« Last Edit: September 05, 2016, 10:44:03 PM by Xavier »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1228
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #1 on: September 03, 2016, 01:25:55 PM »
It seems that setting up "NOT1/2 ==> IM*" in the matrix only adds to all fixed modulation indexes: When setting all fixed IMs to 0.00, and setting the velocity sensitive IMs different from 0.00, the aforementioned matrix entry has no effect at all.
Speaking in simple math, it seems to be implemented similar to this: (fixed IMs * matrix setting) + velocity sensitive IMs
I'd like to see it implemented the following way: (fixed IMs + velocity sensitive IMs) * matrix setting
Does this make sense at all?

Thanks for the feedback, that's interesting.

The formula is : IM = FIX IM + velocity sensitive IMs + matrix value
So it's weird you don't hear any effect when FixIM = 0.
What you hear maybe is that IM<0 in this case it's reset to 0. So it all sounds the same after a certain note number.

TSR

  • Team member
  • *
  • Posts: 8
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #2 on: September 04, 2016, 10:49:20 AM »
To my best understanding, the synth behaves different, just as I stated in the first post.

1) start up the PreenFM2 (On my synth, the patch which shows up is an "Algo 9, Velo 12, Voic 6". I don't know whether this applies in general.)
2) turn OP4 shape to OFF (just using OP1, OP2 and OP3 here)
3) set fixed IMs to 0.00
4) set velocity sensitive IM1 and IM2 > 0.00
5) set up NOT1: FLAT, 60, -LN8
6) set up MATRIX 6: NOT1, any positive value "x", IM*

I cannot hear any dampening effect for the high notes, whatever positive values dialled in for "x". In contrast, dialling in negative values for "x" adds alot of overtones.

Could someone please check.

« Last Edit: September 04, 2016, 10:51:37 AM by TSR »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1228
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #3 on: September 04, 2016, 09:36:59 PM »
Just tried and i agree there is something strange...
I'm trying to indentify the problem.


Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1228
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #4 on: September 04, 2016, 10:01:56 PM »
OK got it.
What is done is  :
Code: [Select]
IM = FIX IM + matrix value
if IM<0 then IM = 0
IM = IM + velocity sensitive IMs.
It's done in different part of the code which is why it was not obvious.

The test is not at the right place and that prevents the Matrix value from diminishing correctly the velocity IM.
I'll try to fix that.

Thanks a lot for the report  :)

Xavier
« Last Edit: September 04, 2016, 11:21:34 PM by Xavier »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1228
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #5 on: September 04, 2016, 10:36:32 PM »

Let me know if this 2.05B5 fix the problem for you.

Xavier

TSR

  • Team member
  • *
  • Posts: 8
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #6 on: September 05, 2016, 05:33:25 PM »
Looks like it is working now as intended!

Many thanks for this quick fix, Xavier!

 :)

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1228
    • View Profile
Re: OS 2.03: behaviour NOT1/2 ==> IM*
« Reply #7 on: September 05, 2016, 10:49:41 PM »
Looks like it is working now as intended!

Great !  :)