Author Topic: New slippers -> no USB  (Read 458 times)

bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
New slippers -> no USB
« on: April 30, 2017, 07:41:14 PM »
My preenfm2 has been working just fine via standard 5 pin midi and midi over usb until a few days ago.

I recently got new slippers which seem to generate a lot of static. Whilst wearing the slippers I touched the preen, I got a static shock and the preen re-booted itself. At the time I had the preen connected to a keystep pro via conventional 5 pin midi and everything seemed to function normally for the rest of the day.

However,  today I noticed that it is no longer appearing in the device list under Windows 10. This is true both as a synth and going through the alternate boot process to make the USB stick visible to the PC.

I've tried connecting to another PC with similar (lack of) results.

The preen itself is able to access the usb stick and I've tried switching firmware versions etc just in case the firmware was corrupted by the static shock.

Apart from consigning the slippers to rubbish bin, where do I start trying to bug fix this issue?


« Last Edit: April 30, 2017, 11:41:10 PM by bigsecret »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1234
    • View Profile
Re: New slippers -> no USB
« Reply #1 on: April 30, 2017, 10:22:22 PM »
Hi,

First check that it's not just a problem of setting that have been reset.
Is the USB over midi enabled ?
Read part 3 here :
http://ixox.fr/preenfm2/manual/menu-mode/
(But as you say USB stick is not visible through the boot loader mode, i doubt...).

Look at the schema in this thread
http://ixox.fr/forum/index.php?topic=69270.0
and check the external USB is still connected to the pin 38 and 39 of the preenF405... (I assume you have a preenF405 and not a CERB40 MCU board)

There's no USB specific chip, USB devices are integrated in the main MCU (microcontroller unit / stm32F4)
There are 2 : 1 for the external USB and one for the USB stick.
I never saw a broken USB on a working MCU.
If that appears to be the case, then you have to change the whole preenF405.

Xavier


bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #2 on: May 01, 2017, 06:37:53 PM »
Hi Xavier

I've checked that USB over MIDI is enabled - but as you say the fact that the memory stick can't be made visible points to a more fundamental issue.

The MCU board says FEZ CERB40 2.0 on the underside.

Pins 38 and 39 are connected to the external USB as per the schematic.

I have taken the MCU out and tried a direct USB connection - but again it's not recognised in any way by the PC.

I've also tried connecting to a Linux PC but the behaviour is still the same - it doesn't show up as a MIDI device when booting normally nor does it expose the USB stick when you got through the boot loader mode.

Just for the completeness I took the stick out and connected it directly to my PC - I was able to copy the 2.07 and a bunch more DX7 sysex files over without any issues.

Given the CREB40 is discontinued - what's my next step? I assume that I just need to buy a replacement MCU and remove the redundant internal USB connection.

Regards

Mark


« Last Edit: May 02, 2017, 09:35:59 AM by bigsecret »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1234
    • View Profile
Re: New slippers -> no USB
« Reply #3 on: May 02, 2017, 11:59:58 AM »
Hi,
OK it's a CERB40.
Seems like there's a problem with the internal mini USB cable....

Can you post a picture of your PCB + CERB40 inserted ?
Thanks
« Last Edit: May 02, 2017, 12:03:02 PM by Xavier »

bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #4 on: May 02, 2017, 03:08:20 PM »
Thanks Xavier



However,  the CERB40 doesn't show up when I remove it from the preen and connect it directly to a PC using a standard USB cable which makes me think the CERB40 is dead (at least the USB bit).



bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #5 on: May 02, 2017, 03:39:30 PM »
I also checked that the internal USB cable is not shorted out.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1234
    • View Profile
Re: New slippers -> no USB
« Reply #6 on: May 03, 2017, 05:28:13 PM »
Did you check the external USB solder joins on the main PCB ?

You can order a preenF405 from the shop.
It should be compatible with your white PCB (check it's a R5 version) and you won't need a internal USB cable.
I'll get it back and reimbourse you if that does not fix anything.
« Last Edit: May 03, 2017, 05:30:06 PM by Xavier »

bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #7 on: May 04, 2017, 09:07:28 AM »
As suggested I have now also checked the external USB socket solder joints. Everything seems good apart from the MCU which doesn't show any signs of life on USB either in or out of the preen.

I've ordered a new MCU - I'm sure this will fix it.

Thanks for the help

Mark

bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #8 on: May 09, 2017, 12:56:29 PM »
Thanks Xavier

The new preenF405  arrived this morning and my Preen is once again visible as a connected device on my PC  :D

I now have a "spare" CERB40 which works just fine as long as you don't want to use the external USB port.

If I'm not careful I'm going to be building another one for my brother-in-law who wouldn't know what to do with the USB port anyway.






Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1234
    • View Profile
Re: New slippers -> no USB
« Reply #9 on: May 09, 2017, 02:20:58 PM »
Cool  :)
Thanks for the update...

opus.quatre

  • Team Member
  • **
  • Posts: 66
    • View Profile
Re: New slippers -> no USB
« Reply #10 on: May 11, 2017, 07:33:21 PM »
Quote
"Preen is once again visible as a connected device on my PC  :D"

oh.. This makes me remark that my own PreenFM is not visible as a device.. Has never been, in fact.. Did I miss something when building it ?? Is there a parameter to set up, somewhere ?

bigsecret

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: New slippers -> no USB
« Reply #11 on: May 12, 2017, 12:57:16 AM »
Yes there is a parameter to set

Read part 3 here :
http://ixox.fr/preenfm2/manual/menu-mode/

Failing that it's down to checking the joints etc
« Last Edit: May 12, 2017, 12:59:44 AM by bigsecret »

opus.quatre

  • Team Member
  • **
  • Posts: 66
    • View Profile
Re: New slippers -> no USB
« Reply #12 on: May 12, 2017, 08:59:37 PM »
Oh.. I see.. Ok, it works.. Thanx Big Secret..