Author Topic: Harsh noise at 13,5kHz from preenFM2  (Read 144 times)

Specter

  • Team member
  • *
  • Posts: 1
    • View Profile
Harsh noise at 13,5kHz from preenFM2
« on: May 11, 2017, 01:24:43 PM »
Hello!

I have recently bought preenFM 2 and there's one thing that bothers me a lot - my unit produces a constant, very thin but loud noise at 13,5kHz.

Here's how it looks on a spectral analyzer:



This is of course very easy to filter out completely due to nature of the noise, but only on digital EQ's using a computer. Not so easy in hardware-based setup though and the sound is very harsh and unpleasant to ears, especially on headphones.

The noise seems to be independent of filters (I tried to put 4 separate filters on every instrument), volume knob (volume does not affect produced noise in any way) and also of power supply (appears on both USB power and DC - might be a tiny bit louder on USB but it's not a big difference 2-3dB tops - you might notice it if you look closely at the spectogram on the left side of my screenshot - this small peak is when I plugged USB cable in. Low noise appears across the whole spectrum after USB cable is plugged in, although much much lower than this 13,5kHz peak).
It also does not change at all no matter what preset is playing and how many parts are in use.

Overall I'm very happy with the instrument and I think Xavier did a WONDERFUL job in designing preen's interface, this is the very first hardware FM synth that I find accessible and actually fun to use. I would love to keep this device but currently this noise bugs me a lot.

Do you have any ideas what could be the reason here and can you tell me how I could possibly fix this issue?

Thank you!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1129
    • View Profile
Re: Harsh noise at 13,5kHz from preenFM2
« Reply #1 on: May 11, 2017, 03:40:37 PM »
Hi,

Yes this come from the yellow OLED display.
Verify your PCB version and read carefully this :
http://ixox.fr/forum/index.php?topic=69159.0

Xavier
« Last Edit: May 11, 2017, 03:42:15 PM by Xavier »

blooper

  • Team member
  • *
  • Posts: 1
    • View Profile
Re: Harsh noise at 13,5kHz from preenFM2
« Reply #2 on: June 11, 2017, 12:56:36 AM »
Does this noise happen with all PCB versions?  Does it happen with R5c?

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1129
    • View Profile
Re: Harsh noise at 13,5kHz from preenFM2
« Reply #3 on: June 11, 2017, 08:17:40 AM »
Does this noise happen with all PCB versions?  Does it happen with R5c?

I just realised there was an PCB version error in the link above. I wrote R4 instead of R5.
Should be clearer now:
http://ixox.fr/forum/index.php?topic=69159.0

The noise come from the yellow OLED display so 'yes'.
With R5c the shield modification is doable but more complicated than with the R5d.
A safe way to avoid the problem is to use a LCD display (unfortunately not compatible with the metal case).

I learnt recently that some web site sells the R5c version   :-\
« Last Edit: June 11, 2017, 08:20:19 AM by Xavier »