Author Topic: Problem starting PreenFM2  (Read 691 times)

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1291
    • View Profile
Re: Problem starting PreenFM2
« Reply #15 on: January 09, 2018, 09:21:03 PM »
No, fat32 is fine.

memorysplice

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: Problem starting PreenFM2
« Reply #16 on: January 13, 2018, 10:45:55 PM »
I got it up and running after I removed and reseated the Preenf405 chip.  For some reason, it was showing the bootloader showing that it was connected but it would not boot until I reseated and soldered the chip in place. 

I do have an issue with the screen display.  Between lines two and line three there are lines above the characters.  Is this normal or do I possibly have a bad screen/ connection with the screen?

lokki

  • Team Member
  • ***
  • Posts: 208
    • View Profile
Re: Problem starting PreenFM2
« Reply #17 on: January 14, 2018, 09:20:07 AM »
glad you got the usb sorted! screen issue is not normal. bad connection seems more likely tbh. maybe resolder those pins (on the screen and on the header) do you have a multimeter? you could check the connections and also look for shorts.

you may also post a picture of the display with the lines (so maybe xavier can debug quicker) and a picture of your soldering on the display and the display headers (so we can see possible shorts/bad joints)


Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1291
    • View Profile
Re: Problem starting PreenFM2
« Reply #18 on: January 14, 2018, 06:00:40 PM »
I do have an issue with the screen display.  Between lines two and line three there are lines above the characters.  Is this normal or do I possibly have a bad screen/ connection with the screen?

Yes, a picture of the display would help to understand what this can be.

memorysplice

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: Problem starting PreenFM2
« Reply #19 on: January 17, 2018, 05:33:49 AM »
Here are the pictures in question.  Should I start a new forum topic addressing the issue?

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1291
    • View Profile
Re: Problem starting PreenFM2
« Reply #20 on: January 17, 2018, 08:47:10 AM »

I saw this for 2 different reasons :
. Bad display
. bad solder on the power pin

Check the second one.
Where did you buy it ? Mouser change without any problem OLED screen if you email them a picture.

memorysplice

  • Team member
  • *
  • Posts: 11
    • View Profile
Re: Problem starting PreenFM2
« Reply #21 on: January 18, 2018, 06:06:51 AM »
I got the screen from eBay.  I will check the power pin.

klangFM

  • Team member
  • *
  • Posts: 13
    • View Profile
    • KlangbauKoeln
Re: Problem starting PreenFM2
« Reply #22 on: April 17, 2018, 07:13:48 PM »
None of my four new Intensio Nano 4GB stick boot at start up.

Press ENG" at startup works and a screen display and reboot is possible, also flashing...

Choose "MTX: DFU" tells me "STM32F4 USB DFU" and I have to restart. What does it means?
One stick boots sometimes after several restarts!

When I change USB stick when running every USB stick boots immediately! Controller permanent looks for a stick. Is a none working USB stick to fast or to slow??


Older Nano 4GB stick works and "pfm2" folder is on stick.


Is there a specification for USB stick to work properly with an original preen controller?



klangFM

  • Team member
  • *
  • Posts: 13
    • View Profile
    • KlangbauKoeln
Re: Problem starting PreenFM2
« Reply #23 on: May 10, 2018, 12:52:27 PM »
Found several 2GB sticks. Tested them and they work. Housing is a bit to big, so I removed it.
If some looking for a working Stick, please send me an e-mail.

loluser22

  • Team member
  • *
  • Posts: 3
    • View Profile
Re: Problem starting PreenFM2
« Reply #24 on: June 16, 2018, 11:43:47 PM »
I got it up and running after I removed and reseated the Preenf405 chip.  For some reason, it was showing the bootloader showing that it was connected but it would not boot until I reseated and soldered the chip in place. 

I do have an issue with the screen display.  Between lines two and line three there are lines above the characters.  Is this normal or do I possibly have a bad screen/ connection with the screen?
I'm having the exact issue you describe, I can get the bootloader running and boot into the bootloader mode, but I cannot boot normally, I just get the full blocks in the OLED. I have a self-made preen405.

I removed the preen405 and put it back in, but it did not help. Did you say that you soldered in place in stead of using the socket?
« Last Edit: June 16, 2018, 11:49:20 PM by loluser22 »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1291
    • View Profile
Re: Problem starting PreenFM2
« Reply #25 on: June 17, 2018, 10:46:00 AM »
....I cannot boot normally, I just get the full blocks in the OLED. I have a self-made preen405....

The full blocks in the display are displayed by the firmwre.
It freeze here if the firmware cannot access the USB drive.
2 possiblities : you didn't t have the expected "/pfm2/" folder or your USB stick is not readable by the preenfm2.

Xavier

loluser22

  • Team member
  • *
  • Posts: 3
    • View Profile
Re: Problem starting PreenFM2
« Reply #26 on: June 18, 2018, 12:45:17 AM »
....I cannot boot normally, I just get the full blocks in the OLED. I have a self-made preen405....

The full blocks in the display are displayed by the firmwre.
It freeze here if the firmware cannot access the USB drive.
2 possiblities : you didn't t have the expected "/pfm2/" folder or your USB stick is not readable by the preenfm2.

Xavier
Great! I've been reflowing the STM32F405 chip all night. Sight, at least is seems I didn't break it, cause I still have the blocks!

But great, my stick is 256MB, an old fellow! Ill try a couple others to see if that fixes the issue! Thanks!

loluser22

  • Team member
  • *
  • Posts: 3
    • View Profile
Re: Problem starting PreenFM2
« Reply #27 on: June 18, 2018, 11:04:38 AM »
Now I don't know what I'm talking about obviously, but: Would it make sense to have the screen say "Reading USB..." instead of just blocks at that point, so that it is obvious that the problem is USB related?

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1291
    • View Profile
Re: Problem starting PreenFM2
« Reply #28 on: June 18, 2018, 11:10:49 AM »
Now I don't know what I'm talking about obviously, but: Would it make sense to have the screen say "Reading USB..." instead of just blocks at that point, so that it is obvious that the problem is USB related?

When i wrote this part of code i didn't expect the USB reading to fail with some USB stick.
But that's a good point ;)