Author Topic: Pushing a saved state from editor to PreenFM2 freezes it! [Fixed in 2.09]  (Read 212 times)

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1324
    • View Profile
Good news  :)

Thanks for the feedback.
Sending to glabal midi fills all 4 instruments at the same time and seems to produce a problem.
Maybe the preenfm2 does not have time to process all midi information and miss some of them.
Or maybe it's a real bug, i'll try when i have time.

Thanks again, for the report and for testing.


Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1324
    • View Profile
OK i found a reproducible CRASH  !!
There were no verification on the incoming midi value for the number of voices. It was directly set on the instrument. It should have been limited like it is when you turn the encoder.
So if you set algo with 6op, number of voices to 4 and pushed it to all instruments (Global midi or same midi channel) it crashed.

If you're not too tired of trying firmware can you try this one with your global midi enabled ?  :)
Thanks
« Last Edit: October 27, 2018, 07:41:01 PM by Xavier »

Yan

  • Team member
  • *
  • Posts: 11
    • View Profile
Not tired at all, the flashing is so quick and it's great that you are so reactive.
So the 2.08f OS solves it all on my side : no freeze even with a global midi channel set up.

Thanks Xavier!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1324
    • View Profile

WOW... thanks a lot.  :D
This was a very annoying bug, i'm glad it's fixed.

I'll publish a new "official" firmware a bit later.