Author Topic: Preen doesn´t start - display is black  (Read 486 times)

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Preen doesn´t start - display is black
« on: February 13, 2019, 10:23:21 AM »
Dear all,

I need your help.
I just finished building my new PreenFM2 (R5d).
Unfortunately, the screen is black. I am using the USB cable connected to the PC. The PC recognizes the USB stick.
But the display is black. Nothing happens.
Attached you will find the pic of my board. Maybe I did a mistake in soldering :-(
Please help me with that.
I am so looking forward to using the instrument.

Thank you!
Mariangela

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1363
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #1 on: February 13, 2019, 10:35:22 AM »
Hi,

Is it the metal case from Van Daal Electronics ?
So your Display is an OLED one ?
If yes, the "OLED" resistor should be populated with a 22ohm resistor.

Xavier

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #2 on: February 13, 2019, 05:45:34 PM »
Hi Xavier,
Thank you so much!
I wasn't sure if I had to put a resistor there.
So, I have done it now. However, nothing happens :-(
USB is recognized. I see its light on. But display is still black.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1363
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #3 on: February 13, 2019, 09:46:33 PM »
What do you see exactly about the USB. The USB key light ?
Can you see the content from the your PC ? That's weird, the preenfm should boot in midi device mode.

Plug the audio, and le me know if you hear a "pop" when you plug your preen.
You can also try to press and hold "INST" and then pree one of the 5 left buttons. You should hear a note.
If not then the problem is not the display.

You can read this thread :
http://ixox.fr/forum/index.php?topic=63509.0
And verify the different points shown of message #6.

That would help also if you can post a better quality pictures of your PCB.




served

  • Team Member
  • **
  • Posts: 70
    • View Profile
    • Van Daal Electronics
Re: Preen doesn´t start - display is black
« Reply #4 on: February 14, 2019, 01:51:43 PM »
Hello,

Thank you Xavier for stepping in.
We sold that DIY kit.

My suggestion would also be that Connect the MIDI cables and try to play it. See if there is any audio coming.

Make better pictures of the oled screen pinheader.
1) OLED screen side pinheader.
2) Mainboard pinheader soldering side.
« Last Edit: February 14, 2019, 01:54:49 PM by served »

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #5 on: February 14, 2019, 07:15:38 PM »
Hi Xavier,

yes, I see the USB key light.
I hear no "pop" when I plug the preen.
I see no content of the USB from my laptop.
I tried to press and hold the buttons you mentioned and so on... but nothing happens.
I send you better pics.

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #6 on: February 14, 2019, 10:45:27 PM »
Here the pics, guys.
Are they enough? Please let me know if you need more.
Thanks!
Maria

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #7 on: February 14, 2019, 10:46:02 PM »
pic 2

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #8 on: February 14, 2019, 10:46:39 PM »
pic 3 and 4

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #9 on: February 14, 2019, 10:48:02 PM »
pic 5

sorry, I couldn´t send all of them at once since I got the notification that they were too large.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1363
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #10 on: February 16, 2019, 06:06:40 PM »
Thanks Maria, but these are very low resolution pictures it's not possible to see potential solder problems.

You should start by checking all your solder points.
Start by all the preenf405 and the display header.

Then have a look at the attached picture and with a multimetre check all colored points.
5V and 3.3v are all required.
2.5v is the DAC output and should not prevent the display to work.

Xavier

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #11 on: February 24, 2019, 12:33:15 PM »
Dear Xavier,

thank you so much.
Sorry if it took so long.
Unfortunately I realized that there was a solder point soldered with another one on the display.
I solved that and I could finally see the display on.
The problem is that I cannot read well. The pixel are not all visible :-(

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #12 on: February 24, 2019, 12:34:11 PM »
I hope you can see the dsplay in the pic.
Many thanks in advance for your precious help.
Regards,
Maria

Maria

  • Team member
  • *
  • Posts: 12
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #13 on: February 28, 2019, 01:05:21 PM »
Hi Xavier,

could you please tell me if I need to buy a new dispay?
Or what can I do to fix it?

many thanks!
Maria

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1363
    • View Profile
Re: Preen doesn´t start - display is black
« Reply #14 on: March 04, 2019, 10:55:54 AM »
Sorry for the late reply. I'm just back from vacation.

That's weird.
You should double check the 0/5V of the display header on the pircutre i attached above.
(With a 22ohm resisor on "oled" you should have around 4.2V on the display header power instead of 5v).
Also verify the the OLED resistor is acutally 22ohm... If to high that could lead to such a problem.

You can also try to shortcut the OLED resisotr with a metal part (resitor leg or something like this) and see if the display works properly.

Xavier