Author Topic: Display weird "12" char  (Read 173 times)

Javelin276

  • Team member
  • *
  • Posts: 21
    • View Profile
    • JavelinArt
Display weird "12" char
« on: December 23, 2019, 05:10:01 AM »
Greetings, I see a display text error, the vertical lines in the Algorithm display are showing up as a number 12.
I'm running 2.11 Beta 1.
« Last Edit: December 23, 2019, 05:13:57 AM by Javelin276 »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1482
    • View Profile
Re: Display weird "12" char
« Reply #1 on: December 23, 2019, 08:24:18 AM »
Greetings, I see a display text error, the vertical lines in the Algorithm display are showing up as a number 12.
I'm running 2.11 Beta 1.

Weird....
I would be surprised it comes from this new firmware.
Didn't you have the same char in 2.10 ?
What is the exact model of display you use ?

matrix12x

  • Team Member
  • **
  • Posts: 89
    • View Profile
Re: Display weird "12" char
« Reply #2 on: December 23, 2019, 02:33:34 PM »
I updated to 2.11 Beta 1. My Algo screen looks normal.

Javelin276

  • Team member
  • *
  • Posts: 21
    • View Profile
    • JavelinArt
Re: Display weird "12" char
« Reply #3 on: December 23, 2019, 03:49:38 PM »
Hmm.  2.08 has the same thing.  I'll take the case off and see if I can see any I'd numbers on the display tomorrow.

Zenman

  • Team member
  • *
  • Posts: 4
    • View Profile
Re: Display weird "12" char
« Reply #4 on: December 23, 2019, 07:17:33 PM »
Just flashed it. No Problems so far. Letters are ok on my device.

Javelin276

  • Team member
  • *
  • Posts: 21
    • View Profile
    • JavelinArt
Re: Display weird "12" char
« Reply #5 on: December 24, 2019, 07:24:35 AM »
OK, I removed the face plate and looked at the OLED Display, but there aren't any markings on the front or sides.  The way the header is soldered in, I can't remove the display without un-soldering the 16 pin header.  The display face frame looks exactly like the form factor of a Newhaven display, either NHD-0420DZ-NSW-BBW or the similar NHD-0420D3Z-NSW-BBW-V3.  Looking through the display manual, I can't see how you get a '12' in a single character position without creating a custom character.  The '|' character is in the table where a '12' is not.  You should be able to access the vertical line character without using a custom one.

It's usable as is, it just looks odd.  Now that I know it's supposed to be a vertical line, I can work around it for now.
« Last Edit: December 24, 2019, 07:28:14 AM by Javelin276 »