Author Topic: PreenFm stop working, blank & werid screen  (Read 307 times)

dzenat

  • Team member
  • *
  • Posts: 7
    • View Profile
PreenFm stop working, blank & werid screen
« on: February 03, 2020, 03:19:44 PM »
hi there,

after some time I managed to have some time with the preenfm again. I bought it as a diy kit, I built it successfully and it was working before but now I can't even start the thing up. Sometimes i get a blank screen and sometimes i get strange acsii lettering. I might have made a mistake once or twice with plugging in the wrong polarity.
So to explain how i get this;

First I plug in in power I get the acsii lettering then the screen doesn't change and stays the same. Then I unplug it and replug power in and then I get black screen, no more letterings. Then I remove power and leave it unplug for some time. After I try again and lettering appear again.
Otherwise the blue lights blink and the light on the usb is on.

I'm uploading some pics to show what happens.

Any ideas how I can fix this?


Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1519
    • View Profile
Re: PreenFm stop working, blank & werid screen
« Reply #1 on: February 04, 2020, 11:25:07 AM »

Looks like bad electric connection between the preenF405 and the display.

Make sure the display is well inserted in the main PCB.
Double check all OLED solder points (on the OLED, on the PCB/femele header).
Also verify the preenF405 is well inserted and check its solder points.


dzenat

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: PreenFm stop working, blank & werid screen
« Reply #2 on: February 05, 2020, 07:27:56 AM »
ok thanks for the reply.

I'll look into that later tonight.

dzenat

  • Team member
  • *
  • Posts: 7
    • View Profile
Re: PreenFm stop working, blank & werid screen
« Reply #3 on: February 18, 2020, 10:44:15 AM »
finally got time to fix this. it's working now, well at least after 2 power up, I get a normal screen. Before reporting on sound and all I realized that when i removed the sides of case, the preenfm powers up properly. There might be something wrong with the usb drive as well. I've got a blue one. At things wriggling it helps. Otherwise, I check soldering jonts and psuh the graphic board deeper, so maybe that help too.

Seems like there's an update on the firmware. I might try to get a new usb to test and update the firmware.

Will try testing sound soon.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1519
    • View Profile
Re: PreenFm stop working, blank & werid screen
« Reply #4 on: February 19, 2020, 03:36:34 PM »
I don't know what firmware you have but upgrading the firmware won't fix you display problem.
Display driver haven't changed for a while.

The Problem you have is definitely bad soldering junction, that sometimes work sometimes doesn't.

Why do you think you have a problem wth the usb drive ?