Author Topic: [fixed in 0.95 ?] preenfm3 sd card error  (Read 1057 times)

Megalomidiac

  • Team member
  • *
  • Posts: 22
    • View Profile
Re: preenfm3 sd card error
« Reply #30 on: October 31, 2020, 09:59:27 PM »
I also bought this wrong display accidentally but never mounted it.
On mine, the SDcard connector is soldered very poorly, it looks, as if someone soldered it manually and there is flux smeared around it.
Have the two people here with the same wrong LCD the same appearance?

I ordered the right display and got it today. There, the SDcard connector is soldered perfectly and clean!
« Last Edit: October 31, 2020, 10:06:11 PM by Megalomidiac »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1710
    • View Profile
Re: preenfm3 sd card error
« Reply #31 on: November 01, 2020, 06:48:19 PM »
Thanks for the update.
Good to know such displays exist...


Olivier

  • Team member
  • *
  • Posts: 10
    • View Profile
Re: preenfm3 sd card error
« Reply #32 on: November 06, 2020, 07:21:14 PM »
I tested my screen with 3,3Volts instead of 5 Volts. Built-in SD card didn't work. Power consumption didn't change.

Have the two people here with the same wrong LCD the same appearance?
It is not so bad, but it is not good.

The SDCard connections on this screen are wrong.

Megalomidiac

  • Team member
  • *
  • Posts: 22
    • View Profile
Re: preenfm3 sd card error
« Reply #33 on: November 08, 2020, 07:15:11 PM »
Finally I had time to solder.
Wanted to make the acrylic case prototype first and then to "marry" the boards and TFT to allign all perfect.

I have installed the latest firmware (0.94) and tested a few cards from a few NoNames, Intensio class 10 16GB, Adata class 10 8GB and none of them worked.

Only a Sandisc Ultra 32GB works!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1710
    • View Profile
Re: preenfm3 sd card error
« Reply #34 on: November 08, 2020, 08:28:52 PM »
Finally I had time to solder.
Wanted to make the acrylic case prototype first and then to "marry" the boards and TFT to allign all perfect.

I have installed the latest firmware (0.94) and tested a few cards from a few NoNames, Intensio class 10 16GB, Adata class 10 8GB and none of them worked.

Only a Sandisc Ultra 32GB works!

Thanks for the report.

Cards that work for me :
. Sandisk Ultra class 10 16Gb
. Patriot LX series class 8 16GB
. EMTC class 4 8Gb
. Sandisk SDHC class 4 4Gb

Cards that does not work:
. Intenso class 10 8Gb
. Transcend class 10 4Gb

I'll try to improve compatibility. But that will take time and it's not straightforward.
Best thing to do today, is to chose a working SD card.
Sandisk ultra seems an easy choice : That's the one

j4ustin

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: preenfm3 sd card error
« Reply #35 on: November 10, 2020, 08:08:57 PM »
I've tried updating my firmware beyond 0.90 but even at 0.91 I can't get any presets to pull up on my SD cards. I've tried 3 different SD cards (2 from Kingston, 1 from a pedal that I got unsure of the brand), and none of them work unless the version is downscaled to 0.90. The system will read the SD card firmware when flashing to go between versions, though.

I have the folder set as pfm3/ at the root with the presets stored. It works going back down to version 0.90 with no changes in place.

Am I missing something here?

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1710
    • View Profile
Re: preenfm3 sd card error
« Reply #36 on: November 10, 2020, 09:41:05 PM »
I've tried updating my firmware beyond 0.90 but even at 0.91 I can't get any presets to pull up on my SD cards. I've tried 3 different SD cards (2 from Kingston, 1 from a pedal that I got unsure of the brand), and none of them work unless the version is downscaled to 0.90. The system will read the SD card firmware when flashing to go between versions, though.

I have the folder set as pfm3/ at the root with the presets stored. It works going back down to version 0.90 with no changes in place.

Am I missing something here?

Sorry about that.

FYI, In 0.91 i changed the way the SD card is accessed to allow loading presest without any audio glitch for other instruments.
I'll try tomorrow (day off in France) to have my "Transcend SD Card" working. Hopefully the other "non working ones" will work also.
If i cannot, i'll compile a recent firmware wth the same SD driver as in 0.90.

j4ustin

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: preenfm3 sd card error
« Reply #37 on: November 10, 2020, 11:10:45 PM »
Thanks Xavier, appreciate your work. This is an awesome instrument!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1710
    • View Profile
Re: preenfm3 sd card error
« Reply #38 on: November 11, 2020, 06:56:08 PM »
v0.95 will hopefully improve a lot SD card compatibility :
https://github.com/Ixox/preenfm3/releases

What did i fix ?
With SD card in SPI mode, when you read data you have to send dummy data to the SD card at the same time.
I was sending 0x00 data. Seems like 0xFF is the standard and some cards require it.


If you still don't see you card, try to format with the official SD card formatter :
https://www.sdcard.org/downloads/formatter/
Copy back your /pfm3/ folder and try again.
That fixes the problem for one of my SD card.

I still have problem with my "Intenso Class 10 8Go" which cannot create big files. So don't create Seq or Mixer Bank with it.

Please let me know how it works for you,

Xavier
« Last Edit: November 11, 2020, 09:25:30 PM by Xavier »