PreenFM > preenfm2 and preenfm3

[FIXED] pfm2 Eurorack : DIY help, frozen screen

(1/4) > >>

I just finished building my preenfm2.  I have the Eurorack version by Van Daal Electronics, but I do still hope you can help me with my problems.  See here

Btw I have read the FAQ.

When I first turned on the module, I got the greeting screen, I got to the edit screen or something (i don't remember, but it looked like in the videos etc), and then it froze, and then it said "!STM32F4 USB DFU!" on the screen.

Whenever I reboot, I usually get a fully lit screen.  So I tried booting up again while holding a button to open the boot menu.  That works fine, but as soon as I boot or something, it starts freezing.  I reformatted the stick and copied the pfm2 folder onto it again, but still it is no better.  I also tried flashing the firmware etc, I still get either a blank fully lit screen, or when I do get to the normal edit menu etc it freezes.

Does someone know what could be wrong?  what should I try doing?  I do think I paid attention that all the soldering was done correctly, but should I check every soldering point again?  Can I do some measurements somewhere?  I hope you can help.


It's a bit confusing.

"!STM32F4 USB DFU!" is only reachable from the bootloader. And it's normal it's frozen at this point, the MCU is waiting to be update through USB (DFU mode).

If the preenfm2 is frozen on a fully lit screen, it's very often a problem with the USB key.
Did you keep the "pfm2/" folder on the key ? It must be there.

Do you have another USB key to try (after copying the pfm2 folder on it) ?

Ok then I guess I have it wrong in memory, or it glitched, I thought that once it suddenly got from the normal preenfm2 edit mode to the USB DFU screen.

I copied the pfm2 folder to my computer, formatted the stick (vfat), and then i copied it to the root directory again.  same behaviour.

i have other usb sticks, but they all have way over 4GB.  Does that make a difference?

Thanks for the help!


--- Quote from: zmberber on October 27, 2020, 04:46:48 PM ---i have other usb sticks, but they all have way over 4GB.  Does that make a difference?

--- End quote ---

No i have some 32Gb key working fine.

So you can give them a try.

Okay, I tried with multiple sticks.  one was a 128 GB, and one was a 4GB.

I got the following behaviour:  The 128GB didn't work at all, just like before (btw the stick I used before was actually 64 GB).  I tried the 4GB stick.  It booted, I was able to do stuff in edit mode for a few seconds, and then it suddenly froze.  And then, as soon as I rebooted, it gave me the fully lit blank screen again.  And this happens over and over everytime I reboot.  think if I wait for a longer time and I power on the module again, I can get to the edit menu again for a few seconds, but then it will freeze again (Or maybe I am just imagining stuff).  Could it be that some capacitor is wrong or faulty?  Is my USB reader broken or something?

Btw thanks again for your quick responses and thanks for your engaged help!


[0] Message Index

[#] Next page

Go to full version