PreenFM Forum

PreenFM => preenfm2 and preenfm3 => Topic started by: Juras on May 01, 2021, 06:25:56 PM

Title: PFM3 display black
Post by: Juras on May 01, 2021, 06:25:56 PM
Hello, today I built Preen FM 3 - kit. After power up yellow led 5v and Gnd 3.3v lights, but display is black.
Jumpers are on Dc in, Boot0 and Tft Vcc 5v.
Should be factory flashed, but no headers was soldered.
Any idea? Do I missing something?
Thanks for help.
Jiri.
Title: Re: PFM3 display black
Post by: Xavier on May 01, 2021, 06:59:14 PM

Hi,

You should also see a blue led slowly blinking.
If not 2 possibilities :
. Do you have the Boot0 jumper set to GND/preenfm3 (and not to DFU)  ?
. The firmware is not flashed.

I carefully flash firmwares on the STM32 before shipping.
I don't need male header, i connect directly to female headers and it works fine. I always check the blue led is on after flashing.

Let m know,

Xavier
Title: Re: PFM3 display black
Post by: Juras on May 01, 2021, 07:07:48 PM
no blue light at all, no blinking, no lighting.
Jumper on right: Boot 0 and Gnd.
So i need to flash fw and bootoader?
Jiri
Title: Re: PFM3 display black
Post by: Juras on May 01, 2021, 09:16:04 PM
After many tries i was i DFU, flashed (DfuSeDemo) bootloader and firmware, now after power up i need to short reset twice, than blue light start to blink and screen shows up now works OK, control board too.
What do you think? Without reset it wont boot up. I am on v0.90.
thanks
Title: Re: PFM3 display black
Post by: Xavier on May 01, 2021, 09:50:57 PM
After many tries i was i DFU, flashed (DfuSeDemo) bootloader and firmware, now after power up i need to short reset twice, than blue light start to blink and screen shows up now works OK, control board too.
What do you think? Without reset it wont boot up. I am on v0.90.
thanks

That's weird.
You told me you desoldered the reset button, double check every thing is clean after you desolder.

Then use latest firmware :
https://github.com/Ixox/preenfm2/releases
v0.90 is the first firmware i published and i'm sure it had lots of problem.



Title: Re: PFM3 display black
Post by: Juras on May 02, 2021, 12:03:56 PM
I moved on. Resoldered all headers, cleaned rest of desoldered reset switch, reflashed DFU, now i can boot to boodloader and normaly preen. Perfect.
But I cannot access SD card "SD Card error" - SD card formated in SD formater Win 10.
In root of the card is p3_0_107.bin. When i boot to bootloader (Menu+power on) SD Card Error. Bootloader 1.01, +/- select, Button 1: Flash... but there is no FW file to select.

When I boot normaly to Preen, again SD card error for few seconds than it looks OK, screen with MIX, all controls from board works.
I cannot see DX presets: Menu - preset - DX7, but its empty. In PC I see: SD/pfm3/DX7/analog_1.syx.

Maybe flash DFU again with latest firmare?

Jiri
Title: Re: PFM3 display black
Post by: Xavier on May 02, 2021, 07:04:45 PM

If you have SD card error, first :
. Upgrade to latest firmware v0.107 / Bootloader v1.07

If still errors :
. Resolder carefully the SD card socket pins on the TFT PCB.

That's a common problem that this socket is not soldered properly by the manufacturor.
Title: Re: PFM3 display black
Post by: Juras on May 05, 2021, 08:10:27 PM
Hello, no luck :-(

1. I resoldered SD card socket pins on display, still SD CARD ERROR

2. I cannot update firmware and bootloader
a)  WebUSB DFU - I have 3 options (VENDOR id) but not as in instruction, screen in attachment, I cannot connect, so firmware download is gray.
b) command line update
Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Deducing device DFU version from functional descriptor length
Cannot open DFU device 0483:df11
No DFU capable USB device available
c) DFU SE Demo - i have only the old pfm3_0.90.dfu, this one I can upload (attachment). This one is currently in preen and preen works.

Is there another option to update FW and bootloader? Or do I missing something?
Or can you create pfm3_1.07.dfu with latest bootloader and firmware?

Thanks for help.
Jiri.
Title: Re: PFM3 display black
Post by: Xavier on May 05, 2021, 10:40:49 PM



I just created a dfu file for latest bootloader and firmware here :
https://github.com/Ixox/preenfm3/releases/tag/v0.107

Also it can be usefull to reformat your SD card with the official SD card formater :
https://www.sdcard.org/downloads/formatter/

The SD card error you have is '#-6#' ?
Title: Re: PFM3 display black
Post by: Juras on May 06, 2021, 09:11:04 AM
Thank you very much, Xavier. DFU flashed, now I am on the latest firmware, ufff. Step by step :-)

Yes, still the problem with SD card, i reformated SD: full format with SD Memory Card Formatter, rewrite all sectors, no quick format, but it did not help.

The SD card error you have is '#-6#' ? - yes, how do you know it?
Should I try another SD cards? Smaller? Or another brand?

Jiri.
Title: Re: PFM3 display black
Post by: Xavier on May 06, 2021, 01:19:40 PM
The SD card error you have is '#-6#' ? - yes, how do you know it?

It means it does not see the SD card at all.
I would really look the SD Card socket again, and the 4 pins connection at the top of the TFT PCB.


Should I try another SD cards? Smaller? Or another brand?

Do you have the SD card from the kit "Sandisk Ultra 16GB" ?
They should work great unless you have a faulty one.
Title: Re: PFM3 display black
Post by: Juras on May 06, 2021, 01:32:40 PM
Yes, using only the Sandisk card came in kit. OK, will try another SD cards, I have many sizes, many brands. Hope I will find one working.
Jiri
Title: Re: PFM3 display black
Post by: Xavier on May 06, 2021, 01:33:30 PM
I edited the message but you replied in the meantime :

> I would really look the SD Card socket again, and the 4 pins connection at the top of the TFT PCB.
Title: Re: PFM3 display black
Post by: Juras on May 06, 2021, 08:27:15 PM
resoldered everything :-) incl. the headers pin on top of LCD and now its working, no error on start, I can load presets... thank you for help.

another problem OUTs. 1-2 distorted sound, 3-4 no sound, 5-6 nice clear sound. All 3 DACs the same orientation. I think DAC boards 1 and 2 need to be resolded?
Jiri
Title: Re: PFM3 display black
Post by: Xavier on May 06, 2021, 08:55:54 PM
resoldered everything :-) incl. the headers pin on top of LCD and now its working, no error on start, I can load presets... thank you for help.

Oh ! good news  :)

another problem OUTs. 1-2 distorted sound, 3-4 no sound, 5-6 nice clear sound. All 3 DACs the same orientation. I think DAC boards 1 and 2 need to be resolded?
Jiri


Yes, and you can also verify the audio Jack solder points.

You can check continuity also with a multimetter as the track is easily visible on the dac small board.
Title: Re: PFM3 display black
Post by: Juras on May 09, 2021, 06:49:57 PM
Finally done! Complete in 3d printed case (7 hours print :-), hole for the SD should be about 3mm-5mm to the top). Some pictures in attachment.
Everything works, now its time for a better part - to make a noise :-)
Thank you Xavier for help, time and patience.
Best regards
Jiri.
Title: Re: PFM3 display black
Post by: matrix12x on May 10, 2021, 03:51:42 PM
Looks really nice in black!