Author Topic: Done!  (Read 5871 times)

aTc

  • Team member
  • *
  • Posts: 2
    • View Profile
Done!
« on: November 21, 2013, 01:31:04 AM »
I just finished building the kit.
It took about 4 hours to get everything done (including a few breaks), and didn't run into any major problems following the guide.

The few minor issues I had were having to solder the usb port in at a slight angle, otherwise I couldn't get my usb stick in properly,
and the knobs on the encoders required quite some force to go down all the way.




Now back to making noise with it.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2061
    • View Profile
Re: Done!
« Reply #1 on: November 21, 2013, 09:46:46 AM »

Congrats and thanks for posting pictures and feedback :D

I already had the problem with the usb port angle, i'll add a note in the guide. Maybe it would be a good idea to solder it with the usb stick in place.

Yes, the knobs are not easy to insert. With a finger (i use the thumb) on the other side of the PCB under the encoder, it goes smoothly though.
I'll add a note too.

Xavier

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2061
    • View Profile
Re: Done!
« Reply #2 on: November 21, 2013, 10:10:00 AM »

The cable from the board to the Cerb40 could be shorter ;-)
From memory 4.5cm is enough... I'll measure it tonight and add it to the build guide.

Xavier

ByteFrenzy

  • Team member
  • *
  • Posts: 4
    • View Profile
Re: Done!
« Reply #3 on: November 21, 2013, 11:18:45 AM »
As for the knobs, *ahem* a bit of lube on the shaft can work wonders...

Oh, this just sounds wrong...

aTc

  • Team member
  • *
  • Posts: 2
    • View Profile
Re: Done!
« Reply #4 on: November 21, 2013, 04:07:22 PM »
Soldering the USB port with the stick in it would only partially solve the problem, since half of it is caused by the legs of the encoder, which go in later.

On the subject of that cable, is it supposed to show up as anything on the host side when you plug the usb cable in ?

And halfway through writing this post I thought of putting the jumper on j3, and it does show up in dfu mode, so at least the wiring is good.

« Last Edit: November 21, 2013, 04:17:27 PM by aTc »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2061
    • View Profile
Re: Done!
« Reply #5 on: November 21, 2013, 04:17:44 PM »
> Soldering the USB port with the stick in it would only partially solve the problem, since half of it is caused by the legs of the encoder, which go in later.

Right.... i'll think about that.

> Midi USB

By default the midi over USB is turned off.
Go in the menu->tools->setting->
Encoder 1 browse the setting entries. Encoder 4 changes the value.
First entry should be "usb midi"  : activate it (input only or input/output).
Click again on menu button and save the config.

You have to reboot the PreenFM to see it in the host..

Let me know,

Xavier

P.S : Note to myself : finish the "menu" documentation.
« Last Edit: November 21, 2013, 04:19:20 PM by Xavier »