Author Topic: [Fixed] not finding DX7 patches?  (Read 6010 times)

deadmonkey

  • Team member
  • *
  • Posts: 6
    • View Profile
[Fixed] not finding DX7 patches?
« on: December 08, 2013, 05:04:35 AM »
I just built my PFM2 and it works great but when I load DX7 there are no patches to load. I downloaded a couple of hundred DX7 patches and put them in pfm2/dx7 on the USB stick. Any ideas?
« Last Edit: December 11, 2013, 10:11:30 PM by Xavier »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2039
    • View Profile
Re: not finding DX7 patches?
« Reply #1 on: December 08, 2013, 01:52:16 PM »

Which one did you download ?

Did you get "SYX files (1,177,600 byte tar file)" from here :
http://homepages.abdn.ac.uk/mth192/pages/html/dx7.html#patches
?
No subfolder... Directly in "pfm2/dx7"..

The PreenFM2 can only read dx7 *.syx... Check the size it should be 4104.

Xavier

deadmonkey

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: not finding DX7 patches?
« Reply #2 on: December 08, 2013, 06:41:57 PM »
I did but I added a couple of additional groups of syx files from the same site, all of them are in pfm2/syx. Is there a limit on the number of files that could cause this to happen?

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2039
    • View Profile
Re: not finding DX7 patches?
« Reply #3 on: December 08, 2013, 06:59:41 PM »
I did but I added a couple of additional groups of syx files from the same site, all of them are in pfm2/syx. Is there a limit on the number of files that could cause this to happen?

You mean "pfm2/dx7" ?
Limit is 256 dx7 sysex files. But if you put more, only 256 will show up.

Use the zip file provided, and let me know if you see analog1 bank in Load->DX7.

Xavier

deadmonkey

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: not finding DX7 patches?
« Reply #4 on: December 08, 2013, 07:56:15 PM »
sorry, yes, its the pfm2/dx7 directory. I re-downloaded and extracted the sysex tar and put the contents in pfm2/dx7 without the additional patches I had in there earlier and it works now. The problem may be the first patch from the group "DX7EXTRA" which is called $m3.syx. It looks like the directory scan is interrupted by the $ and it won't find any files after that.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2039
    • View Profile
Re: not finding DX7 patches?
« Reply #5 on: December 08, 2013, 08:44:29 PM »
sorry, yes, its the pfm2/dx7 directory. I re-downloaded and extracted the sysex tar and put the contents in pfm2/dx7 without the additional patches I had in there earlier and it works now. The problem may be the first patch from the group "DX7EXTRA" which is called $m3.syx. It looks like the directory scan is interrupted by the $ and it won't find any files after that.

Ah i see... thanks for the report.

Tip for the DX7 patches, if you have a saturated sound, look at the upper oscillator number (ENG button + Menu), set it to "SIN" if it's not already and reduce the frequency.
Having frequency = 16 at level 3 or 4 works with the DX7 not with the PreenFM.

I'll try to automate this in a future update.

XAvier

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2039
    • View Profile
Re: not finding DX7 patches?
« Reply #6 on: December 08, 2013, 10:35:01 PM »
It was not because of '$'.
It was stupid bug that sets the number of bank to 0 if more than 256 syx files.

Fixed in 0.9j, thanks for the report.

Xavier
« Last Edit: December 08, 2013, 10:38:05 PM by Xavier »

deadmonkey

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: not finding DX7 patches?
« Reply #7 on: December 08, 2013, 10:42:29 PM »
aha! Thanks!