Author Topic: PreenFM2 new build, audio is mostly noise  (Read 1526 times)

Glomerule

  • Team member
  • *
  • Posts: 5
    • View Profile
PreenFM2 new build, audio is mostly noise
« on: May 17, 2021, 04:45:06 PM »
Hello fellow PreenFM enthusiasts,

I'll start by saying that I am more than impress the whole initiative and that this really is the kind of project the world needs more of (in every domain).

Biggest shout-out to Xavier.

So here is my story.
A few weeks ago, I saw a mention of the PreenFM2 on reddit r/synthesizer and was intrigued. One or two youtube videos later I was hooked and ready for a sleep deprivation fueled impulse buy.  8)
The Vandaal website was all out of assembled PreenFM2 R6 so I went to the second link, TubeOhm and bought what I thought was an already assembled synth.

Spoiler alert: it was not.

Yesterday I decided to give it a go. I have no soldering skills (a few jacks and midi cables is all that I have soldered before that, and not even very well...).
It almost went smoothly and the most complex thing ended up being the software part as I thought it was pre-flashed when in fact it was not.

Anyway, cutting short, I have a fully assembled PreenFM2 with the latest firmware (not the latest bootloader though, I did not find a version above the 1.11) that responds to midi (the channel number is blinking on note input).

The sound it produces though is not what it should be for sure.
It is constantly there even without input note. It is mostly noise with the FM patch behind. It reacts to preset loading or algorithm change etc but there is this constant noise that I cannot shake off.

There is no instruction on how to install the DAC on the new R6 but the very clear picture on the PCB makes it quite obvious so I think I did it the right way.

Sound example: https://www.dropbox.com/s/23efcyzytpwjm8h/postassembly_noise.mp3?dl=0

I have no idea where it comes from and I'd be really much obliged if someone from the community could help me a bit.

I can post photos or other sounds or even videos if needed of course.

Thank you for your help!



lokki

  • Sr. Member
  • ****
  • Posts: 356
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #1 on: May 18, 2021, 08:04:41 AM »
Some hires photos of the front and back of the PCB will be very helpful. Does the noise disappear/diminish when you turn down the volume on the preenfm2

served

  • Team Member
  • ***
  • Posts: 124
    • View Profile
    • Van Daal Electronics
Re: PreenFM2 new build, audio is mostly noise
« Reply #2 on: May 18, 2021, 08:12:10 AM »
It kindof works. So You must have the most of the circuit done correctly.
So its now the question of the analog part and there is few parts only that can be involved. So Send us the pictures!

Glomerule

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #3 on: May 18, 2021, 09:45:35 AM »
Thank you fellas !

here are front and back shots:




I couldn't remove the screen this morning but I'll do it if you think it matters.

Another clue might be this:
When I plug it for power, be it usb or DC, if I use my little Bose speaker that has a metal case, there is a strong noise appearing whenever I touch the metal... I don't have that if plugging in my mixer.
 It seems relevant but what do I know !

Thanks again.
 

served

  • Team Member
  • ***
  • Posts: 124
    • View Profile
    • Van Daal Electronics
Re: PreenFM2 new build, audio is mostly noise
« Reply #4 on: May 18, 2021, 12:06:14 PM »
Resolder the small green DAC pcb. It looks bad solder there.
Also look over all the solderpoints. You have a lot of bad soldering going on.
The screen (both sides), encoders, DC jack etc.
« Last Edit: May 18, 2021, 12:08:52 PM by served »

Glomerule

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #5 on: May 18, 2021, 12:26:59 PM »
Haha, 'bad soldering' doesn't even begin to describe it !

I will redo the whole soldering of the DAC as you advise after watching a few video tutorial...

For the rest I might redo them later anyway but since the screen and all the encoders seem to be working fine, don't you think I can leave them like that for the time being ?
Thank you for your help !

served

  • Team Member
  • ***
  • Posts: 124
    • View Profile
    • Van Daal Electronics
Re: PreenFM2 new build, audio is mostly noise
« Reply #6 on: May 18, 2021, 02:45:56 PM »
IF it works. Yes. You can leave them.
But Re-flow the DC jack. Volume potentsiometer and DAC. Also Output jacks are worth looking at.

Some tips for soldering.
1)Clean the tip regulary.
2) Heat the station to about 330to360 Degrees C (depending on your model)
3) Put the soldering-iron tip against the PCB and component leg and then apply some solder. First to a very little to the tip and then to the soldering area.
Keep adding the solder unitl the parts is soldered in.

Never solder with a tip that has a lot of solder on.
Apply most of the solder to the PCB and part leg, not to the soldering-iron-tip.

You anly need a very small amount of solder on the tip. It helps to transfer the heat. But its the only reason its there.

Glomerule

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #7 on: May 18, 2021, 04:33:20 PM »
Great list of tips (haha) I will try all that as soon as I have the time.
I can't wait to make music but I have to say that even if I'm really bad at it (now but not forever I hope) I am discovering that I enjoy the process and having some guidance by people like you is really precious.

I am really grateful.

PS:
Does the noise disappear/diminish when you turn down the volume on the preenfm2

Hard to tell, it is really messy but when I listen the audio file I linked again, knowing that I am increasing the volume little by little, it seems that the notes get louder but the noise volume stays constant...

lokki

  • Sr. Member
  • ****
  • Posts: 356
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #8 on: May 19, 2021, 12:49:45 AM »
definitely redo the DC jack soldering... also redo the USB port soldering. (can't see it underneath the display)
DAC is certainly a good idea as well :-)

as you describe the issue (with the noise increasing when you touch a connected speaker) this sounds like a non existing/bad ground connection maybe..

Glomerule

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #9 on: May 20, 2021, 03:31:29 PM »
Ok, as Alice would say, it is getting 'curiouser and curiouser' but it might just be me being really bad at all this.

I tried to correct my bad soldering after watching a few how-to videos on youtube. It seems that the tip of my soldering iron is busted making the whole thing quite difficult. I couldn't manage to really de-solder / re-solder the DAC and other component but I think I managed to make it a bit better.

The infernal buzzing is still here but I can hear the FM synth a bit better and the buzzing does not increase when I turn up the volume knob !

I have a new problem though, The screen does not work anymore  :-\ ...

I used a multimeter to test continuity and everything seems fine (as far as I can tell) for all the components aside from some pin on the screen socket (picture below) being 'connected' (I took notes of which on a post-it that I of course lost immediately after), do you know if it might be why the screen stays black ?

Thanks for your input.



matrix12x

  • Team Member
  • ***
  • Posts: 142
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #10 on: May 20, 2021, 05:48:37 PM »
If your soldering iron tip is busted, definitely get a new tip. Also, I suggest you buy some flux and use it to reflow the bad solder joints.

mckruithuijb

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #11 on: June 17, 2021, 04:47:30 PM »
Very curious if this is solved yet, I seem to have the same problem see also my post: http://ixox.fr/forum/index.php?topic=69844.0

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2011
    • View Profile
Re: PreenFM2 new build, audio is mostly noise
« Reply #12 on: June 17, 2021, 11:02:25 PM »

The solder joints on the picture above are really bad.
I'm not surprised some bad junction may lead to bad communication between the MPU and the DAC.
The master DAC clock is around 20Mghz. Bad junction may lead to noise in the 20Mghz clock.
Without this clock the DAC cannot work properly.

Try to resolder the 8 DAC pins on both side.
If it still does not work, you can try the volume pot.
Then the audio JACK.