Author Topic: Noise/Clipping when using filter on pFM3  (Read 236 times)

NickDS

  • Team member
  • *
  • Posts: 8
    • View Profile
Noise/Clipping when using filter on pFM3
« on: May 26, 2022, 12:44:39 PM »
Hello, when using filter on pFM3 (especially audible on LP,LP2,LP3,Hp,HP2 etc..) there is a clipping/noise at the very start of every playing note. It is not a gain problem. It is when an unused voiced gets used the filter seems to cause a clipping at the attack. This attack clipping doesn´t seem to happen when the voice is already in use and a note change happens. So it always happens at a start of a fresh voice.

I know this kind of effect on analog filter, in very low ranges sometimes the higher frequencies are still leaking through in the attack, but adjustable with a little sweetspot finding in the attack of the envelope... But i am not sure if that pFM3 problem is comparable. But maybe a little? is there some kind of an adjustable attack parameter in the Filter code that is causing this problem? would be nice if this issue could be considered in the next build.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: Noise/Clipping when using filter on pFM3
« Reply #1 on: May 28, 2022, 06:21:27 PM »

Hi,

Can you share a preset where i can hear what it sounds like ?
Easiest way would be to save as default Mix MENU>MIXER>DEFL>SAVE
And then share, the file MIX.DLF that you'll find on the SD Card.

Thanks

NickDS

  • Team member
  • *
  • Posts: 8
    • View Profile
Re: Noise/Clipping when using filter on pFM3
« Reply #2 on: May 29, 2022, 02:42:47 PM »
Hi Xavier,

i´m sorry, it seems to be not a Filter issue! My Midi Keyboard is connected to a sequencer and then per midi out of the sequencer to the pfm3 midi in. When i press the Stop button on the sequencer it instantly stops/resets the voices (instant stops the release sound) of pfm3 to zero. So when the sequencer sends notes again, or i play with the keyboard you have this clippi/noisy effect.

I think you cant reproduce this effect because of my routing with the sequencer, but I put a .mp3 file in the attachement, there you can heare me press the stop button of the sequencer and how it stops the release and then how the clipping sounds afterwards wehn playin again... strangely when i turn of the filter there is no clipping/noise. And when i connect the keyboard (Keystep) directly to the pfm3 there are also no clippings...

I can not deactivate sending the Stop message of my sequencer to the pfm3, maybe thats the issue?