Author Topic: [Solved] New VanDaal build, control board does nothing  (Read 802 times)

Eamoex

  • Team member
  • *
  • Posts: 22
    • View Profile
Re: New VanDaal build, control board does nothing
« Reply #15 on: July 01, 2022, 10:45:04 AM »
Using DfuSe on my Win10 laptop (on which I've intalled the dreaded STM USB driver) does allow me to revert back to 0.90 and recover the initial failed state (everything works except control board).

Situation:

on the PC
  • DfuSe: error-free but there's no *.dfu file with the latest bootloader/firmware available
  • webdfu: will not connect to the device (I guess because of the evil STM driver?)

on the Mac (10.15.7)
  • DfuSe: I don't find a Mac version
  • webdfu: gives errors and "bricks" the device
« Last Edit: July 01, 2022, 10:52:45 AM by Eamoex »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2136
    • View Profile
Re: New VanDaal build, control board does nothing
« Reply #16 on: July 01, 2022, 04:29:16 PM »
As DfuSe seems to work for you, i'll create a file for it with latest bootlader/firmware later today. That can be usefull.

If you want to give another try yourself, only flash the pfm3 bootloader (p3_boot_1_09.bin) at 0x08000000 with webdfu on your Mac.

Then you should be able to boot in the pfm3 bootloader by pressing MENU while turning on.
From the pfm3 bootloader, you can easily flash the firmware (p3_0_110) that must be copied on the SD Card. Just read the screen instruction.

P.S : I confirm you cannot brick your preenfm3 : Boot0/DFU jumper on, always boots to a system (STM32) bootloader that cannot be erased.
« Last Edit: July 01, 2022, 04:30:55 PM by Xavier »

Eamoex

  • Team member
  • *
  • Posts: 22
    • View Profile
Re: New VanDaal build, control board does nothing
« Reply #17 on: July 01, 2022, 05:20:05 PM »
As DfuSe seems to work for you, i'll create a file for it with latest bootlader/firmware later today. That can be usefull.

Great, thanks for that.

If you want to give another try yourself, only flash the pfm3 bootloader (p3_boot_1_09.bin) at 0x08000000 with webdfu on your Mac.

Then you should be able to boot in the pfm3 bootloader by pressing MENU while turning on.
From the pfm3 bootloader, you can easily flash the firmware (p3_0_110) that must be copied on the SD Card. Just read the screen instruction.

Well, what do you know... it worked! Using address 0x08000000 instead of the default one seems to have done the trick, although webdfu still returned an error message at the end of the flash. After that, I was able to enter the pfm3 bootloader with the MENU button and flash the 110 firmware onboard... phew!

Thanks a lot for your support. Can be tagged as [SOLVED].

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2136
    • View Profile
Re: New VanDaal build, control board does nothing
« Reply #18 on: July 02, 2022, 06:51:47 PM »
Oh nice ! Thanks for the update.  :)