Author Topic: PreenFM2 USB issues.. (Windows 7 / 64bit)  (Read 22041 times)

RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #15 on: December 13, 2013, 05:46:59 PM »
https://www.ghielectronics.com/community/forum/topic?id=10068&page=2

Some seem to get it working after some time, some dont.. but my main problem is, i got it detected by windows now, but still no DFU Listing. Also no detecting with connecting the PreenFM over USB. Only via direct connection to CERB40 in DFU Mode.
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #16 on: December 13, 2013, 08:20:40 PM »
Also no detecting with connecting the PreenFM over USB.

Could you give more details ?
For the moment i don't know if it's the same problem or 2 different ones.

Please confirm :
> USB Midi is enabled AND saved in the settings. Press 2 times "Menu" after enabling "USB Midi: In" in Menu->Tools->Set.
Plug mini USB cable to CERB40 AND PreenFM Powered.
The Reboot your PreenFM. Usb midi only works when it's enable while it's booting.

What do you see in the device manager ?
"PreenFM mk2" should show up in a folder called something like "audio, games devices"...
Do you see it ?
Screenshot appreciated ;-)
« Last Edit: December 13, 2013, 08:25:21 PM by Xavier »

RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #17 on: December 13, 2013, 09:01:18 PM »
Hello

If i connect the PreenFM directly on his own USB Port it will not detect anything, no unknown device, no hidden device, nothing!
Of course i enabled the Midi in the Tools Menu i also tried all the ports, powered hubs, non powered hubs, different cables, also had the preenFM2 upside down while shuffle dancing at a full moons night, nothing worked  8)

i could make a screenshot but this would not help, because you wouldnt see any PreenFM device on it.
I guess i have to life with that, maybe i will buy a CERB40 on my next mouser order and try another one.
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #18 on: December 13, 2013, 09:11:42 PM »
If i connect the PreenFM directly on his own USB Port it will not detect anything, no unknown device, no hidden device, nothing!

There is no unknown device... this is a standard MidiStreaming device : http://www.usb.org/developers/devclass_docs/midi10.pdf
It does not need any driver and work out of the box on Linux, MacOs, IOS and Windows.

Sorry I was not clear.
I want to be sure it's not your PCB->miniUSB cable that is the problem.
Can you do ALL your test with a cable directly from you computer to the mini usb port of the  CERB40 in adition  to the way you power the PreenFM (USB or DC in).

After, If you really think your CERB40 has a problem, send it back to me, i'll send you another one.

Xavier



RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #19 on: December 13, 2013, 09:22:54 PM »
Hey Xavier

I think we are getting nearer to the problems source
I was able to get the System to show "PreenFM mk2" once (having the USB Cable directly connected to the CERB40 and also connected the preenFM on the backside via another USB cable)

so it must be the connection on the PCB somewhere..
I already double checked if i soldered the USB Connector pins right, but its exactly like in the pic. Also minimum solder, nice solder joints, no cross connections, also reflowed.

I still dont know why i cant flash a new bootloader on it in DFU Mode, even if i would fix the USB PCB Connection problem, i would never be able to update my bootloader (or are there any other ways ?)

Will look further on the USB PCB Connection ports...
« Last Edit: December 13, 2013, 09:26:33 PM by RyuX »
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #20 on: December 13, 2013, 09:37:22 PM »

Ah.... finally good news  :D

Re-flashing the bootloader should not be usefull at all.

bootloader 1.01 fixed a problem for some LCD (not the one from the kit).
bootloader 1.02 light the LED and that's all


RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #21 on: December 13, 2013, 09:41:42 PM »
Yeah but still, i like my gear fully functional even if i dont use it :D
Cant seem to find the reason why the onboard USB Pins dont work, everything seems nice.
Will have a more detailed look tomorrow, and take everything apart again  :-[

Thanks for the help so far Xavier..
Have a good night
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #22 on: December 13, 2013, 10:43:40 PM »

An other Idea for the DFU mode.

Unplug the PreenFM.
Try to uninstall all USB devices with vendorID "0483" and productId "df11".
With USBDeview :
http://www.nirsoft.net/utils/usb_devices_view.html#DownloadLinks

Then restart one more time the whole process.


RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #23 on: December 14, 2013, 07:13:54 PM »
Hello
this did not help either..

But the good news is, i found the problem why the USB did not work.
It was a bad trace from Pin3 to USB Port of PreenFM. i am just about to fix it, i had no continuity between USB pin 3 and the USB Connector.

Seems that at least i have one problem solved soon ;)
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #24 on: December 14, 2013, 07:25:11 PM »
:D
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

RyuX

  • Team member
  • *
  • Posts: 21
  • Trapped in the 80's
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #25 on: December 14, 2013, 10:35:49 PM »
It shows up and syncs to bpm now via USB, but when i try to send midi notes to an instrument it does not respont, tried all channels. Dont know why that is, i checked the Channel assignment etc. seems all ok, but ok baby steps, at least i got it detected and fixed the bad trace.

Made a short video, thanks for integrating the BPM Sync LED in the new Firmware after i asked you if that would be possible.
I skipped the 220 ohm resistor and used a 5mm UV LED, looks nice in person, the video does not do it any justice.

http://youtu.be/qzsjqDGQzKU


Note: I fixed the Midi Channel issue, dont know what exactly caused it, but it is working now, via USB directly, just restarted my computer ;)
« Last Edit: December 14, 2013, 10:53:33 PM by RyuX »
http://www.soundcloud.com/ryu-x/  [my soundcloud]
http://chipmod.blogspot.com/    [my electronics blog]
http://ryuxblog.tumblr.com/      [my photography blog]

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #26 on: December 15, 2013, 03:07:20 PM »

The BPM LED was simple but great idea, and easy to code. Thanks  ;)

Does this big led affect the sound when blinking on long notes ?

Could be solder on the top PCB side with a hole on the black controle surface... I'll have to try that.

Xavier

werazefu

  • Team member
  • *
  • Posts: 4
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #27 on: January 06, 2014, 01:32:00 AM »
I had exactly the same problem: The PFM2 wasn´t recognized. No way. Not even connected straight to the CERB40.

I found out that I damaged the Mini-USB jack with my self assembled Mini-USB plug. I don´t know why but I pushed two of the five contact stripes out of the back of the jack. That was very hard to find. I hardly could see it. So there was no contact at line 3. I pushed them back in. But the were broken. Fortunately I was able to solder a little piece of metal (cut from a resistor) between the two dead ends.

All at once: It works! I was able to install the driver and update the bootloader.

6581punk

  • Team Member
  • ***
  • Posts: 110
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #28 on: January 06, 2014, 09:55:28 AM »
The USB cable is the most problematic part of the build. Although mine only seemed to work after resoldering the USB socket (power worked but not data).

One thing that would help is if the USB pins had their actual signal type mentioned on the silkscreen. So D- and D+ as well as 2 and 3. Or just put that information on the website somewhere.



Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2123
    • View Profile
Re: PreenFM2 USB issues.. (Windows 7 / 64bit)
« Reply #29 on: January 07, 2014, 11:45:51 AM »

Yes the usb cable is the most sensitive part to build.
I would love a CERB40 with 2 aditional pins instead of the mini usb connector.

Thanks for the feedback, i'll add the D+, D- information somewhere.

Xavier