Author Topic: [solved] SD Card Issues...  (Read 1383 times)

Schatzy

  • Team member
  • *
  • Posts: 6
    • View Profile
[solved] SD Card Issues...
« on: March 21, 2021, 05:30:28 PM »
I have just finished assembly of my PreenFM3 and I cannot get the SD card to function.  I am running V0.105 and am powering the unit from the USB connection.  I am using one of the recommended "Sandisk Ultra - SDHC UHS-I Card" 16GB card.  It has been formatted as FAT32 by the recommended "SD Card Formatter" program.

The Preenfm3 appears to be functioning well as I am able to use the editor and MIDI ports and generate tones etc.  It only appears to be that the SD Card is not functioning.

I loaded the pfm2_usb.zip onto the SD Card and then tried moving the contents to a /pfm3/ subdirectory on the card using my laptop.

I have a few of questions:
1. Is the SD Card supposed to be r/w accessible to my computer as a typical memory card?
2. What is the expected directory structure for the files on the SD Card when used on my PreenFM3?
3. I get an error code of #-6# on the tft at powerup of the Preenfm3.  Is it possible that I have a jumper incorrectly strapped that would cause this to occur?  It appears that the connectors and operation of the tft are working correctly as a display. The SD connector on the display is present and connected to the Preenfm3.

Any comments or suggestions would help!  Thank you...
« Last Edit: March 23, 2021, 08:14:07 AM by Xavier »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1995
    • View Profile
Re: SD Card Issues...
« Reply #1 on: March 21, 2021, 06:12:09 PM »
Hi

1. To access the SD card once it's in your preenfm3, you have to boot in the bootloader.
     See bottom of this page.
    In regular usage, the USB is used as a midi interface and you don't see the SD card from a computer.

2. https://github.com/Ixox/preenfm3/wiki/SD-card
If something is lacking or not clear in this page, please let me know.

3. There's nothing special to do to have the SD card working.
    #-6# means the preenfm does not see any SD card.
    you may have one of the wrongly wired TFT.
    Please Attached a picture were we can see how is wired to SD card socket on the TFT PCB, or check that the wire is as shown on the attached picture.
    If you have the top SD card pin wired, it's wrong and cannot work.
   

Schatzy

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: SD Card Issues...
« Reply #2 on: March 21, 2021, 08:51:12 PM »
Attached you will find a picture of the TFT and the connector that I used to plug it into the PreenFM3 PCB.

If there is a wiring error, is it something that I may rewire to fix?  I see that the three series matching resistors R1, R2, and R3 are not on my TFT.  Also R5 is not installed on my TFT.

Thank you!
-Jeff

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1995
    • View Profile
Re: SD Card Issues...
« Reply #3 on: March 21, 2021, 09:21:22 PM »
Attached you will find a picture of the TFT and the connector that I used to plug it into the PreenFM3 PCB.

This TFT is good.
You can double check the connection from the SD socket to the preenfm3.
You can also try to resolder the SD socket pins, someone told me he fixed a SD card problem by resoldering them.

Schatzy

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: SD Card Issues...
« Reply #4 on: March 21, 2021, 10:32:01 PM »
I verified all the soldering with an eye-loop and only have issues with cleaning the flux off the board. 

I attached a photo of the back of my board so that you may be able to see if I am missing anything as far as the SD card and the configuration.  I compared my configuration with the photo that you published in the documentation and I have just a couple of things different.  The DC-IN jumper is not in my CFG because I am currently powering through the USB port.  I assumed that the SWD connector is for programming the processor and put pins there.  I have not added any other wire changes to this project.
Any comments?  (I definitely appreciate the time you are putting into this!  We are going to build the second PreenFM3 tonight!)

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1995
    • View Profile
Re: SD Card Issues...
« Reply #5 on: March 22, 2021, 08:10:35 AM »
Yes, SWD is for "Serial Wire Debug" to programm the STM32.
The SD Card is wired directly to the STM32 so it should work as soon as the preenfm is powered without any jumper condition.

Can you resolder the 4 pins on the top to the TFT/SD card, these are responsible for the SD connection.
Then you can try to check continuity between the 4 points (1,2,3,4) and the other side on the top of the TFT PCB with a multimeter.
If you have 2 TFTs, you can also try the other one.

And also try another SD card (but i'm 99% sure that does not come from the SD card).

« Last Edit: March 22, 2021, 11:49:21 AM by Xavier »

Schatzy

  • Team member
  • *
  • Posts: 6
    • View Profile
Re: SD Card Issues...
« Reply #6 on: March 22, 2021, 11:57:23 PM »
Problem solved!
Some of the pins on the SD Card socket were not soldered!  It wasn't the 4 pin connector, it was the SD Card connector on the display! See the circled connector pins.
Finally took my Preen upstairs to my shop and probed around a bit with an oscilloscope.

olicash

  • Team member
  • *
  • Posts: 1
    • View Profile
Re: [solved] SD Card Issues...
« Reply #7 on: April 13, 2021, 10:38:00 AM »
Just want to say thanks for this, got my pfm3 working!

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 1995
    • View Profile
Re: [solved] SD Card Issues...
« Reply #8 on: April 14, 2021, 09:08:10 AM »

I also just had a TFT when i have to re-solder the SDCard socket to make it working.
It's not hard, but this is someting we have to keep in mind.