Author Topic: [solved] PreenFM2 r6 no boot after build  (Read 3127 times)

Blaise

  • Team member
  • *
  • Posts: 5
    • View Profile
[solved] PreenFM2 r6 no boot after build
« on: March 25, 2021, 08:31:47 PM »
Hi ! :)

I just finished my preenfm2 r6 build from van daal electronics, and when i power it, it does nothing. No audio, not even noises or cracks, and the OLED stays black.

Quote
Latest beta version : 2.20b1

If you have a PCB R6 SMD, you need this version to get any sound out of the preenfm2.
If you flash the PCB for the first time, please follow the steps here :
https://github.com/Ixox/preenfm2/tree/master/flash
And use the dfu file attached to the release.

Do I need to do this or is my PCB already flashed to the latest version ?

Cant wait to hear the synth :)
Ty
« Last Edit: March 28, 2021, 05:30:05 PM by Xavier »

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2152
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #1 on: March 25, 2021, 09:36:32 PM »

Hi,

2 possibilities.
1. You put a jumper on Boot0 on the PCB
2. The firmware is not flashed

If the answer to 1 is "No", so you have to follow the steps you mentioned to flash bootlaoder and firmware.
But don't use 2.20b1. It was the first one that support the new DAC, use 2.21 instead :
https://github.com/Ixox/preenfm2/releases


Blaise

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #2 on: March 25, 2021, 10:47:22 PM »
Ok so now every cell in the screen is lit when i power it normally, but if I hold a button i can access bootloader v1.11.

I guess next step is to install the firmware ?

I've been following these instructions : http://ixox.fr/preenfm2/preenfm/upgrade-firmware/

On my USB key there's a single folder called "pfm2" with DX7, scala folders and some .bnk files. And also a p2_2.12.bin file.
But when i press the flash button in bootloader mode it doesnt show any option.
Also i cant see my usb stick after pressing ENG in bootloader mode

As you mentioned the latest firmware is 2.21, i've downloaded the pfm2_2.21.zip from your github and copied it at the root of my USB key, but pressing flash still doesnt show any files on the synth.

Thank you for your time :)

matrix12x

  • Team Member
  • ***
  • Posts: 153
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #3 on: March 25, 2021, 11:28:23 PM »
Sounds like a USB stick issue. You may want to try a different USB stick.

Blaise

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #4 on: March 26, 2021, 12:29:33 AM »
Just to be sure i updated to bootloader 1.13 from the version 2.20 folder, and i tried to install firmware v2.21 with a different USB stick. It looks like it worked, but not totally.

Now when i power the synth normally it doesnt boot. I have to start it in bootloader mode, press the flash button, screen says "no /pfm2 folder, rebooting" and after reboot it works perfectly.
Also it looks like the synth is running 2.20, but im sure i put the p2_2.21.bin file in the /pfm2 folder on the USB key.


Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2152
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #5 on: March 26, 2021, 08:40:37 AM »

Cool. Flashing the bootloader is more diffult part.


Also it looks like the synth is running 2.20, but im sure i put the p2_2.21.bin file in the /pfm2 folder on the USB key.

Firmware is not executed from the USB key, you have to flash it from the USB key to the preenfm MCU.
See (2) here :
http://ixox.fr/preenfm2/preenfm/upgrade-firmware/

Blaise

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #6 on: March 28, 2021, 11:40:17 AM »
Hi :) Thank you for your help !

Okay so yesterday i bought a new USB key, then everything was working as expected.
My synth is now running v2.21 and everything works fine :)

I just have 2 little problems left :

- There's a lot of noise on the synth, but im powering it via USB so i guess maybe using an external power supply will get rid of that.
- It looks like i cant control the synth via midi IN cable. Is it supposed to work as soon as I plug something in ? I tried with an MPC One (MPC midi out to preenfm midi in), an electric piano (piano midi out to preen midi in) and via the midi OUT on a USB audio interface. Tried loading a combo on the preen then tried to send commands on channel 1/2/3/4 with external gear via the midi din cable. I expected to hear instruments 1/2/3/4 but nothing worked.

Hardware-wise, i've never soldered a midi cable before so maybe I missed something, but i've soldered IN 4/5 on the board to pins 4/5 of the midi IN connector, and pins OUT 4/5 on the board to the pins 4/5 of the midi OUT connector.

Almost there ! :)

And again thank you really much for your help !

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2152
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #7 on: March 28, 2021, 12:32:01 PM »

Thanks for the update.

Yes use a 9v DC in power supply to get rid of the noise.
Or find a good dedicated USB wall adapter.
Powering it from a computer is the worst.

You can define the midi channel in the Menu>Tools>Set.
Default is 1/2/3/4 for instrument 1/2/3/4.

And yes it should work immediatly.
You may have inversed pins 4/5 on the midi socket, double check that.


Blaise

  • Team member
  • *
  • Posts: 5
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #8 on: March 28, 2021, 01:39:37 PM »
Ok so i inverted the pins on the midi connectors and everything works fine.
And I also got rid of the noise by finding a good USB adapter and using midi to control the synth.

Merci Xavier :) Et bravo pour le synthé, c'est une super machine.
Honnêtement je savais pas qu'il fallait flasher le soft dessus, d'ou le dérangement (et merci pour ta réactivité d'ailleurs :)), mais à postériori je dirais que c'était vraiment pas très compliqué. Le kit R6 est vraiment simple à monter pour une machine de cette qualité. Belle itération. Franchement bravo.

Xavier

  • Administrator
  • Hero Member
  • *
  • Posts: 2152
    • View Profile
Re: PreenFM2 r6 no boot after build
« Reply #9 on: March 28, 2021, 05:29:56 PM »
Ok so i inverted the pins on the midi connectors and everything works fine.
And I also got rid of the noise by finding a good USB adapter and using midi to control the synth.

Merci Xavier :) Et bravo pour le synthé, c'est une super machine.
Honnêtement je savais pas qu'il fallait flasher le soft dessus, d'ou le dérangement (et merci pour ta réactivité d'ailleurs :)), mais à postériori je dirais que c'était vraiment pas très compliqué. Le kit R6 est vraiment simple à monter pour une machine de cette qualité. Belle itération. Franchement bravo.

Cool thanks for the update  and thanks for the nice words :)